Geforce とOpenGL

GeForceではOpenGL非対応と思い込んでみたが、使用中の
GeForce GTX 560M についてnVIDIA社に問い合わせたところ、openGL4.1に100%互換とのこと。CAD系のソフトが体感問題なくちゃんと使えているのは、このためなのか。

ちなみに最新のRTX2060-2070-2080も、 Microsoft® DirectX® 12 API, Vulkan API, OpenGL 4/5 対応すべてYESとなっている。

ということはOPENGLへの対応推奨というだけであればQuadroを使用せずCPUを十分機能させたGeforce使用で足りてしまうはずなのだけど?